
RYAN INTERNATIONAL SCHOOL LUDHIANA 

SESSION – 2014-15 

CLASS - IX 

SUBJECT – COMPUTER 

PRACTICE WORKSHEET – I 

I. Fill in the blanks. 

1.) Computer is an electronic device. 

2.) DVD works in the same way as CD – ROM but packs more data than bits in the same work 
area. 

3.) 0 and 1 are binary digits. 

4.) Any data fed by the users through a keyboard is called input. 

5.) Whenever data is fed by the user, it is processed by CPU (Central Processing Unit) for the 
output. 

6.) Data fed is translated into Machine language/ Binary codes for processing. 

7.) Joystick is an input device mainly used for games. 

8.) A scanner is an input device. 

9.) The CPU is a combination of a CU and ALU. 

10.) A Printer is an output device, which produces hard copies as an output. 

11.) Laptop is a portable computer. 

12.) Example of secondary memory is CD-ROM 

13.) OCR reads approximately 750 documents per minute. 

14.) RAM is a volatile memory by nature. 

15.) Mathematic calculation is done in computer by its ALU. 

16.) Internal storage is known as primary memory. 

17.) Software is a set of instructions that directs the hardware. 

18.) A computer system is classified as hardware and software. 

19.) Software can be categorized as system and application software. 

20.) A virus program is also software. 

21.) An operating system is an interface between user and computer. 

22.) Shareware is the software developed for public domain and hence can be copied without 
infringing copyright. 

23.)  Free software is the software that is freely accessible and can be used, modified, 
improved, copied and distributed free of charge. 

24.) Proprietary software has restrictions on copying, modifying and using the software. 

25.) DOS is a single user operating system. 

26.) Compiler is a software that translates the entire program into machine code in one go. 

27.) Interpreter is software that translates the program into machine code line by line. 

28.) Assembler is a language translator which translates the assembly language into machine 
code. 
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29.) Tailor made software is designed according to the need of an organization. 

30.) Virus scanners are used to scan for computer viruses among files and folders. 

II. State True/False. 

1.) The cycle that the computer hardware and software follows is known as IPO cycle.  True 

2.) Data is known as output of the computer. False 

3.) Dot matrix printer was the most popular printer that prints one character at a time. True 

4.) Internal Memory is also not known as Immediate Access Store (IAS). False 

5.) CPU is the brain of a computer system. True 

6.) Control Unit only controls the memory of computer.  False 

7.) Light pen is mainly used for developing design applications.  True 

8.) Soft copy is permanent once you save it.  False 

9.) ROM is known as Read Only Memory.  True 

10.) Local Carry Device is abbreviated as LCD.  False 

11.) Inkjet Printers are slower than Laser printers. True 

12.) A group of 8 bits is called Nibble.  False 

13.) External memory is also called secondary memory.  True 

14.) Keyboard is not used commonly.  False 

15.) Computer performs operations on data fed to process it.  True 

16.) Software is classified in four types.  False 

17.) An antivirus program is a utility program.  True 

18.) An operating system is known as applications software.  False 

19.) Programs written in high level language is called source program.  True 

20.) FORTRAN is an example of assembly language.  False 

III. Multiple Choice Questions. (Choose the most appropriate option) 
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IV. Answer the following. 

1.) What is a Computer? 

Ans: Computer is an electronic device that accepts input from the user, process it (data) and 

gives output (Information) to user. 

2.) What is hardware? 

Ans: The physical components of computer that can be touched or see are called hardware. Eg. 

Mouse, Keyboard, Scanner etc. 

3.) What is Software? 

Ans: Software is a set of instructions that instructs the hardware for step – by – step operations. 

4.) What are different types of software? 

Ans: (i) System Software    (ii) Application Software  

5.) What do you mean by an input? 

Ans: Input is the data put into the computer. It goes into a process, supported by storage. 

6.) What do you mean by an output? 

Ans: Output is the processed form of data. 

7.) Write names of input devices. 

Ans: Keyboard, Mouse, Scanner, Light Pen, Track Ball, Joystick, Bar code reader, OCR, MICR, 

OMR, Microphone etc. 

8.) Write names of output devices. 

Ans: Monitor, Printer, Plotter and Speaker. 

9.) What is the use of memory or storage of a computer? 

Ans: The memory or storage section of the computer stores the data and information that could 

be used during the computations. 

10.) What is RAM? 

Ans: RAM stands for Random Access Memory. It is a primary memory. It is volatile by nature. The 

data/ instructions, which are stored in it can be modified or deleted. 

11.) What is ROM? 

Ans. ROM stands for Read Only Memory. The instructions to start/ shut the computer are stored 

in it. It is permanent memory. It is non- volatile by nature. The data/ instructions, which are 

stored in it cannot be modified or deleted. 
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12.) What is VDU? 

Ans: VDU stands for Visual Display Unit and it is a device used for viewing output. It is well known 

as monitor. 

13.) What is the basic language of computer? 

Ans: Machine language (Binary code i.e. 0 and 1) is the basic language of computer. 

14.) What is an Operating System? 

Ans. Operating system is a set of programs that acts as an interface between the user and the 

computer. It controls overall activities of the computer system i.e. input, process, output and 

storage. 

15.) Differentiate Open Source Software, Free software, Shareware and Proprietary software. 

Ans: Open Source Software: The source code of this software is available under a license. The 

users are thus permitted to study, change and improve the software. It is developed in a 

collaborative manner. Open source licenses include Apache License, GNU General Public License, 

BSD License, and GNU Lesser General Public License. 

        Free Software: This software is freely accessible and can be used, modified, improved, 

copied, distributed and is available free of charge. 

        Shareware Software: Shareware is developed for the public domain which can be copied 

without infringing copyright. This software is released on trial basis. 

       Proprietary Software: This software has restrictions on copying, modifying and using the 

software as enforced by the proprietor. 

16.) What is an assembler? 

Ans: An assembler is language translator that converts assembly language into machine code. 

17.) What is the difference between Compiler and Interpreter? 

ANs:  

 

18.) What is the purpose of virus scanning software? 

Ans: Virus Scanning Software is utility programs designed to protect your computer from viruses. 

It scans your disk each time you insert it into a computer. 

Compiler Interpreter 

Translates the entire program 
into machine code in one go. 

Translates the program into machine 
code line by line. 

Execution takes place when all 
syntax errors are removed. 

Execution takes place when all syntax 
errors of a line are removed. 

Debugging is slow. Debugging is faster. 

Execution time is less. Execution time is more 
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19.) Define Disk defragmentation. 

Ans: Disk defragmentation means to divide a large file, which cannot be stored in one location of 

the disk, in parts and stored at different locations or blocks of the disk. 

20.) What is System Software? 

Ans: System Software is a set of programs that controls the internal operations of the computer. 

It has three categories further as:  

       (a.) Operating System  (b.) Language Translator   (c.) Utility Programs 

21.) What is Application software? 

Ans: Application Software is a set of programs written for specified application. It can be 

classified as:  a.) Integrated Package (b.) Tailor Made Software (c.) General Purpose 

Package 

22.) What is Utility software? 

Ans: Utility Software is specially designed to help and manage the computer hardware, operating 

system or application software. 

23.) Define Integrated Package. 

Ans: Integrated Package includes several application programs combined in one easy to use 

package. 

24.) Define Tailor made software. 

Ans: Tailor- made software’s are designed according to the needs of an organization. This 

software can be very expensive. 

25.) Define General Purpose Package. 

Ans: General purpose package are pre-installed on the computer and can be used in many ways. 

Eg. Ms- Word, Ms- Excel and Ms- PowerPoint etc. 

V. Abbreviations. 

1.) COMPUTER – Commonly Operated Machine Particularly Used in Technical and Educational 

Research 
2.) CD – Compact Disk 

3.) DVD – Digital Versatile Disk 

4.) ASCII – American Standard Code for Information Interchange 

5.) ALU – Arithmetic Logic Unit 

6.) CPU – Central Processing Unit 

7.) CAD – Computer Aided Designing 

8.) CAM – Computer Aided Manufacturing 

9.) DPI – Dots Per Inch 
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10.)  GUI – Graphical User Interface 

11.)  CUI – Character User Interface 

12.)  MICR – Magnetic Ink Character Reader 

13.)  OMR – Optical Mark Reader 

14.)  OCR – Optical Character Reader 

15.)  VDU – Visual Display Unit 

16.)  RAM – Random Access Memory 

17.)  ROM – Read Only Memory 

18.)  LCD – Liquid Crystal Display 

19.)  LED – Light Emitting Diode 

20.)  BIT – Binary Digit 

VI. Draw a flowchart to categorized different types of software. 

 
 

VII. Draw a flowchart to categorized different types of Memory. 
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RYAN INTERNATIONAL SCHOOL LUDHIANA 

SESSION – 2014-15 

CLASS - IX 

SUBJECT – COMPUTER 

PRACTICE WORKSHEET – II 

I. Fill in the blanks. 
1.) The operating system is a complex piece of software that is loaded automatically into 

memory when the computer is started. 
2.) The clipboard viewer allows you to work with the contents of the clipboards. 
3.) Text files normally have .TXT file extension. 
4.) WordPad is more useful for letters and reports. 
5.) Loading a file means opening a file. 
6.) The collection records is known as file. 
7.) Rename command allows us to rename the name of selected folder. 
8.) You can get into the file menu by pressing Alt+F. 
9.) To copy selected file press Ctrl + C. 
10.)  A Folder contains files. 
11.) The entire document can be selected by keyboard shortcut Ctrl + A. 
12.) F7 function key is used to check the spelling and grammar. 
13.) MS – Word is a word processing software. 
14.) We choose open option from File menu to open the existing file. 
15.) Numbering option can add or remove numbers from selected paragraph. 
16.) Scroll bar is used to move the current page up and down. 
17.) Menu bar is situated just below the title bar. 
18.) Spacing adjusts the amount of space between letters. 
19.) Red wavy line in your text indicates spelling mistake. 
20.) For making the text Bold and Italics, click Bold, Italics buttons in Font group. 
21.) The Shading command colors the background behind the selected text. 
22.) The default alignment of text in MS Word is left. 
23.) For creating a bulleted list, click Bullets in Paragraph group. 
24.) The shortcut key to align the text in right is Ctrl+R. 
25.) Superscript option creates small letters above the line of text. 

II. State True/False. 
1.) MS Windows is a GUI Operating system. True 
2.) Copy option works in the same way as the Cut option. False 
3.) Deleted files can be retrieved from the Recycle Bin. True 
4.) WordPad is more useful than MS – Word.   False 
5.) My Computer gives you a separate window for each object.   True 
6.) You select Cut and Copy option from the Format menu.  False 
7.) Paint provides you with several tools to create a bitmap.  True 
8.) Clear command places the selected text on the clipboard.  False 
9.) Whenever you start MS Word, it automatically creates a blank document.  True 
10.) The spelling checkers of MS Word cannot check the grammatical spelling errors.  False 
11.) Hard copy is printed document.  True 
12.) Grammatical mistakes cannot be found by using grammatical check option.  False 
13.) The whole document can be printed by choosing Office button> Print.  True 
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14.) You should use page down to go to previous page.  False 
15.) At the time of Print Preview, useful word menu items are not available. True 
16.) The print icon is located in View group.  False 
17.) Using the table features of MS Word you can make your time table.  True 
18.) F3 key can be used to select the current paragraph.  False 
19.) Collate option helps to arrange the printed documents.  True 
20.) You cannot insert pictures or graphics to a word document.  False 
III. Multiple Choice Questions. (Choose the most appropriate option). 
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IV. Answer the following. 

1.) What is a Window? 

Ans: Window is a just a rectangular box, which is a visual area for displaying output and allowing 

input for a computer process. 

2.) What do you understand by an operating system? 

Ans: An operating system acts as an interface between the user and the computer. It controls 

overall the activities the computer system. 

3.) What is an icon? 

Ans: An icon is a graphical symbol, which represents application program or documents. Clicking 

the icon runs an application or open a document. It is a tool for making computer interfaces 

easier. 

4.) What does GUI stands for? 

Ans: GUI stands for Graphical User Interface. 

5.) What is the difference between a file and a folder? 

Ans: Folder is a collection of files and file is a collection of records. 

6.) Distinguish between copying and moving files. 

Ans: When we copy a file, a duplicate file is created and the original source file is not distributed. 

But whenever a file is moved to a new location, the original file is not retained. 

7.) What is the difference between Title Bar and Menu Bar? 

Ans: The title bar is the topmost bar of a window, which displays the name of active application. 

The menu bar is situated just below the title bar. It displays various menus for the users to 

choose as per their requirements to perform the tasks. 

8.) What is the Restore button? 

Ans: Restore button restores the size of the application window to its original size. 

9.) What happens when you delete a file? What is the use of Recycle bin? 

Ans: When we delete a file, it goes to the recycle bin. Recycle bin is a part of the hard disk, where 

all deleted files are stored. A deleted file can be retrieved from the recycle bin. 
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10.) What is a word processor? How is it useful? 

Ans: Word processor is a software program, which processes the word function. It can be used to 

prepare documents like letters, report, notices, bills etc. 

11.) How will you start the MS Word to create your documents? 

Ans: Click on Start > All Programs > Microsoft Office > Microsoft Office Word 2007. 

12.) How will you save your document? 

Ans: Document can be saved by pressing Ctrl+S or clicking on File > Save As. 

13.) What are the shortcut keys for the following – Cut, Copy and Paste? 

Ans: Cut : Ctrl + X  Copy : Ctrl + C  Paste : Ctrl + V 

14.) What is text alignment? 

Ans: Text alignment is a position of text in the document. For example – left, right and center. 

15.) What do you understand by word wrap? 

Ans: When a text does not fit in a line to its right, it is automatically shifted to next line at starting 

point, is called word wrapping. 

16.) What do you mean by the indent and indentation? 

Ans: The distance between the text boundary and the page margin is indent and the process of 

doing is called indentation. 

17.) What do you mean by clipboard and what is its utilization? 

Ans: Clipboard is a temporary storage area, and it is used to store cut/copy text and graphics and 

these cut/copy text and graphics are used for pasting/ copying elsewhere. 

18.) What is the function of auto correct in MS Word? 

Ans: Auto correct feature looks for typing errors and corrects them automatically. 

19.) How will you insert a Shape in your document? Explain. 

Ans: Shapes can be inserted in a document by selecting Insert > Shape. It has buttons for basic 

shapes, lines, arrows, flow charts, banners, callouts and other similar shapes, click any of these 

options. 

20.) How will insert a Clip Art picture into a word document? 

Ans: MS Word has the option to insert picture in a word document. For inserting a picture in a 

word document from Clip Art Gallery click, Insert  > ClipArt. Clip Art pane on the right side of the 

screen appears. Select the desired category. 
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